PTA 1019 数字黑洞
给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174
,这个神奇的数字也叫 Kaprekar 常数。
例如,我们从6767
开始,将得到
7766 - 6677 = 10899810 - 0189 = 96219621 - 1269 = 83528532 - 2358 = 61747641 - 1467 = 6174... ...
现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。
输入格式:
输入给出一个 (0,10
^4) 区间内的正整数 N。
输出格式:
如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000
;否则将计算的每一步在一行内输出,直到 6174
作为差出现,输出格式见样例。注意每个数字按 4
位数格式输出。
输入样例 1:
6767
输出样例 1:
7766 - 6677 = 1089 9810 - = 9621 9621 - 1269 = 8352 8532 - 2358 = 6174
输入样例 2:
2222
输出样例 2:
2222 - 2222 = 0000
C#版代码如下:
using System;
using System.Collections.Generic;
namespace _1019
{
class Program
{
static void Main(string[] args)
{
/* var strA = strIN.ToCharArray();
List<char> listC = new List<char>();
foreach (var item in strA)
{
listC.Add(item);
}
listC.Sort();*/
const string str6174 = "6174";
string strIN = Console.ReadLine();
strIN = int.Parse(strIN).ToString("0000");
string C = string.Empty;
while (C != str6174)
{
List<char> listC = Kap(strIN);
string A = listC[3].ToString() + listC[2] + listC[1] + listC[0];
string B = listC[0].ToString() + listC[1] + listC[2] + listC[3];
C = (int.Parse(A) - int.Parse(B)).ToString("0000");
strIN = C;
Console.WriteLine(string.Format("{0} - {1} = {2}", A, B, C));
if (listC[3] == listC[2] && listC[2] == listC[1] && listC[1] == listC[0])
{
return;
}
}
}
static List<char> Kap(string strIN)
{
var strA = strIN.ToCharArray();
List<char> listC = new List<char>();
foreach (var item in strA)
{
listC.Add(item);
}
listC.Sort();
return listC;
}
}
}
最后:
注意题中提到的数字区间,并且在例题中若是3位数需用0在前补齐为4位数,也就是说输入有可能是小于4位的数字,需要自行在前用0补齐,这个很重要,有几个测试点就涉及这个。
注意数字相同时的输出,并且输出后即结束。
输出格式需要注意 A - B = C A后有空格,B前后有空格,C前有穿格。